آموزش ارتقاء به CustomBuild 2.0 در دایرکت ادمین

شروع موضوع توسط AHMAD ‏Jul 24, 2015 در انجمن دایرکت ادمین DirectAdmin

  1. AHMAD

    AHMAD ایران وب ادمین عضو کادر مدیریت ناظر انجمن

    سلام

    برای ارتقاء CustomBuild از ورژن های 1.1 یا 1.2 به CustomBuild 2.0 باید طبق دستورات زیر عمل کنید :

    ابتدا از طریق SSH به سرور خود متصل شوید.

    سپس دستورات زیر را به ترتیب وارد کنید :

    کد:
    برای مشاهده محتوا شما بایستی ثبت نام کنید.
    در این مرحله در صورتی که می خواهید تغییراتی در تنظیمات پیشفرض CustomBuild 2.0 بدهید (به عنوان مثال ورژن php یا آپاچی را تغییر دهید ، IonCube ، Zend و .. را نصب کنید و ..) فایل options.conf را توسط یک ویرایشگر (مانند نانو با دستور nano options.conf) ویرایش کرده و مقادیر مورد نظرتان را جایگزین کنید و سپس با دستور ctrl+x هنگام خروج تغییرات را ذخیره کنید.

    سپس دستورات زیر را وارد کنید تا ارتقاء به کاستوم بیلد 2 انجام شود :

    کد:
    برای مشاهده محتوا شما بایستی ثبت نام کنید.

    موفق باشید


    .
     
  2. amin

    amin عضو تایید شده کاربر انجمن

    سلام
    با تشکر از شما
    من تمام مراحل بالا رو رفتم اما با ارور زیر مواجه میشم
    کد:
    برای مشاهده محتوا شما بایستی ثبت نام کنید.
    مشکل از کجا میتونه باشه؟

    من مراحل زیر رو هم طی کردم اما تاثیری نداشت
    کد:
    برای مشاهده محتوا شما بایستی ثبت نام کنید.
    آپشن:

    کد:
    برای مشاهده محتوا شما بایستی ثبت نام کنید.
     
    آخرین ویرایش: ‏Nov 28, 2015
  3. msm

    msm عضو حرفه ای عضو کادر مدیریت ناظر انجمن

    سلام
    این خطا ارتباطی به ارتقا کاستوم بیلد نداره احتمالا وقتی کاستوم بیلد رو آپدیت کردید برای نصب سرویس ها با ورژن جدیدتر نیاز به لایبراری هایی داره که رو سرور شما نیست اول کاند زیر رو بزنید تا این موارد نصب به بعد بیلد آل کنید مشکلتون احتمالا رفع میشه
    کد:
    برای مشاهده محتوا شما بایستی ثبت نام کنید.
     
    amin از این پست تشکر کرده است.
  4. amin

    amin عضو تایید شده کاربر انجمن

    با تشکر از شما
    من این مورد را در سایت دایرکت ادمین دیده بودم. انجام دادم اما متاسفانه همچنان ارور قبلی تکرار می شود.
    فکر می کنم برخی تنظیمات options.conf شاید با هم سازگاری نداشته باشه؟
     
  5. msm

    msm عضو حرفه ای عضو کادر مدیریت ناظر انجمن

    ورژن php رو روی 5.5 ست کنید چون 5.6 هنوز استیبل نیست ممکنه رفع بشه اگر نشد نیاز به دسترسی هست تا بتونم چکش کنم
     
  6. amin

    amin عضو تایید شده کاربر انجمن

    تشکر از شما
    با suphp مشکل داشت. میگفتmod_ruid2 با تطابق نداره
     
  7. msm

    msm عضو حرفه ای عضو کادر مدیریت ناظر انجمن

    بله suphp با mod_ruid2 همزمان نمیتونن فعال باشن
     
  8. amin

    amin عضو تایید شده کاربر انجمن

    من قبل از ارتقا به کاستوم بیلد جدید و آپدیت موارد فوق از suphp استفاده می کردم.جالب اینه که با فعال بودن suphp و غیر فعال کردن mod_ruid2 هم ارور 500 می داد. دسترسیها هم درست بود و 777 هم اصلا نداشتم.
    هرکار کردم نشد از SUPHP استفاده کنم. آیا راه حلی به نظرتون میرسه؟
     
  9. farshid

    farshid مدیر کل انجمن عضو کادر مدیریت مدیر کل انجمن

    سلام
    بهتر هست لاگ وب سرورتون رو ببینید که چه خطایی میده و دقیقا چه اتفاقی میافته که خطای 500 بهتون میده بعد میشه بررسی بهتری کرد و راه کار بهتری بهتون پیشنهاد داد.
    در مسیر /var/log سرورتون لاگ وب سرور رو بررسی کنید یا ارسال کنید تا دوستان یا بنده بهتر بتونن راهنمایی تون کنند.
    چون خطای 500 عوامل خیلی زیادی داره.
     

به اشتراک بگذارید

س