عوض کردن مسیر پوشه نصب whmcs و خطای ادمین

شروع موضوع توسط pcnethost ‏Sep 12, 2016 در انجمن WHMCS

  1. pcnethost

    pcnethost عضو تایید شده کاربر انجمن

    درود

    من لایسنس whmcs را از سایت فراسو تهیه کردم و سیستم را نصب کردم.

    الان مسیر نصب پوشه را عوض کردم . یعنی از پوشه اصلی به یک ساب فولدر انتقال دادم.

    ناحیه کاربری دون مشکل باز میشه ولی در هنگام ورود به ادمین با خطای 404 مواجه می شوم.

    ممنون میشم راهنمایی کنید . آیا باید لایسنس تغییری پیدا کنه ؟ یا من باید در فایلها تغییری ایجاد کنم ؟

    با تشکر

    موفق و سربلند باشید
     
  2. AHMAD

    AHMAD ایران وب ادمین عضو کادر مدیریت ناظر انجمن

    سلام
    معمولا بعد از تغییر مسیر WHMCS باید یکبار لایسنس را Reissue کنید اما مساله این هست که اگر Reissue نکنید خطای 404 دریافت نمی کنید و این خطا احتمالا دلیل دیگری دارد.
    لطفا یکبار لایسنس را Reissue کنید اگر مشکل برطرف نشد بفرمایید.
     
    pcnethost از این پست تشکر کرده است.
  3. ruin3r

    ruin3r مدیر کل انجمن عضو کادر مدیریت مدیر کل انجمن

    سلام.
    باید مسیر دقیق ادمین رو در فایل کانفیگ قرار دهید.
    کنترل پنل هاست شما چیست؟سی پنل یا دایرکت ادمین؟
     
    pcnethost از این پست تشکر کرده است.
  4. pcnethost

    pcnethost عضو تایید شده کاربر انجمن

    با تشکر از پاسخ شما بزرگوار

    کنترل پنل سی پنل هستش .

    من لایسنس رو از کنترل پنل فراسو Reissue کردم.

    خط زیر هم به فایل کانفیگ اضافه کردم و درست نشد

    $whmcspath = '/home/username/public_html/whmcs/';

    مسیر دقیق ادمین به چه صورت میشه ؟
     
  5. pcnethost

    pcnethost عضو تایید شده کاربر انجمن

    پس از انتقال چه فایلهایی و به چه صورت باید ویرایش شود ؟
     
  6. msm

    msm عضو حرفه ای عضو کادر مدیریت ناظر انجمن

    سلام
    داخل فایل کانفیگ
    کد:
    برای مشاهده محتوا شما بایستی ثبت نام کنید.
    mycustomfoldername بجای این نام فولدر ادمین خود را وارد کنید
     
  7. msm

    msm عضو حرفه ای عضو کادر مدیریت ناظر انجمن

    این خط رو حذف کنید این خط برای فایل کانفیگ پوشه crons هست که اگر مسیرش رو تغییر بدید نیاز به وارد کردنش دارید
     
  8. pcnethost

    pcnethost عضو تایید شده کاربر انجمن

    درود

    با تشکر از همه دوستان و اساتید عزیز مشکل حل شد

    راه حل هم در همین پست میذارم که اگر دوستان دیگه نیز به همین مشکل برخوردند راهنمایی بشه.

    کد زیر در htacsess مشکل ساز بوده است

    RewriteRule .* index.php [L]
     
  9. msm

    msm عضو حرفه ای عضو کادر مدیریت ناظر انجمن

    این اولین موردی بود که باید بررسی میکردین ! فک میکردم از این مرحله گذشتین و حل نشده
    تشکر از اشتراک راه حل
     

به اشتراک بگذارید

س